Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 05, 2025 - 02:30 UTC
Scheduled
Dear Customer, We would like to inform you of a scheduled maintenance window for the FortiEdge Cloud platform.
Upgrade Details • Date: November 04, 2025 • Maintenance Window: 6:30 PM to 8:30 PM PST • Expected Duration: 2 hours • Domain: Canada/Europe/USA/Japan Please subscribe to Status Page Portal to receive notifications once the maintenance window is complete.
Impact During Upgrade: • Brief intermittent access to the FortiEdge Cloud portal may occur during the upgrade process • Device management functions may experience temporary limitations • API services may be temporarily unavailable
Important: Your network infrastructure (Extenders, Switches, and Access Points) will continue to operate normally and provide uninterrupted service to end users during the maintenance window. Only cloud management functions will be temporarily affected.
Posted Oct 27, 2025 - 19:10 UTC
This scheduled maintenance affected: Canada(Global) (REST API, Network Management Portal, Main Dashboard), Europe (REST API, Network Management Portal, Main Dashboard), Japan (REST API, Network Management Portal, Main Dashboard), and USA (REST API, Network Managment Portal, Main Dashboard).