Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 08, 2026 - 23:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Feb 27, 2026 - 04:35 UTC
Scheduled
Dear Customer,
We want to inform you of a scheduled maintenance window for the FortiEdge Cloud platform.
FortiStack zone Dallas-a will undergo a scheduled FortiGate firmware upgrade.
During this maintenance, user workloads may experience minimal packet loss or minor degraded performance. The FMS portal is expected to remain fully accessible.
UTC PST (Pacific Time) 23:00 PST, March 8, 2026 ---- 01:00 PST, March 9, 2026
EST (Eastern Time) 02:00 EST, March 9, 2026 ---- 04:00 EST, March 9, 2026
UTC 06:00 UTC, March 9, 2026 ---- 08:00 UTC, March 9, 2026
Thanks, FortiEdge Cloud Team
Posted Feb 27, 2026 - 04:34 UTC
This scheduled maintenance affected: USA (REST API, Network Managment Portal, Main Dashboard).