Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 15, 2026 - 03:01 UTC
Scheduled
Dear Customer,
We want to inform you of a scheduled maintenance window for the FortiEdge Cloud platform in US.
During this time, you may experience: - Brief intermittent access to the FortiEdge Cloud portal. - Some integrated services will be unavailable for roughly 1 hour - Temporary limitations in device management functions. - Temporary unavailability of API services. - Users may encounter brief service interruptions during this time.
Important: During this maintenance window, FMS portal is expected to remain fully accessible. Your network infrastructure (Extenders, Switches, and Access Points) will continue to operate normally and provide uninterrupted service to end users during the maintenance window. Only cloud management functions may be temporarily affected.
Maintenance Window
UTC 03:00 UTC, April 15, 2026 ---- 05:00 UTC, April 15, 2026
PDT (Pacific Time) 20:00 PDT, April 14, 2026 ---- 22:00 PDT, April 14, 2026
CDT (Central Time) 22:00 CDT, April 14, 2026 ---- 00:00 CDT, April 15, 2026
EST (Eastern Time) 23:00 EST, April 14, 2026 ---- 01:00 EST, April 15, 2026
Posted Apr 09, 2026 - 22:34 UTC
This scheduled maintenance affected: USA (REST API, Network Managment Portal, Main Dashboard).