FortiEdge Service Disruption – USA Domain

Incident Report for FortiEdge Cloud

Resolved

This incident has been resolved.
Posted Apr 24, 2026 - 21:55 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 24, 2026 - 19:33 UTC

Investigating

We are currently facing an issue affecting the USA domain.

Our team is actively investigating the root cause and working to restore services as quickly as possible.

We will share further updates as soon as we have more information.

We apologize for the inconvenience and appreciate your patience.
Posted Apr 24, 2026 - 19:18 UTC
This incident affected: USA (REST API, Network Managment Portal, Main Dashboard).